1
0
Fork 0
mirror of https://gitlab.com/SIGBUS/nyaa.git synced 2024-07-21 20:28:09 +00:00
nyaa/.travis.yml
Nicolas F d8e796f3e0 Move to Python 3.7 and update dependencies (#551)
* forms: replace re._pattern_type with re.Pattern

Python 3.7 removed re._pattern_type and replaced it with
re.Pattern.

* readme: update for Python 3.7

* Update requirements

Also remove some unused ones which were neither a direct dependency
nor a dependency of our dependencies.

* account: force ASCII usernames on login form

Our database doesn't like it when we check for unicode data in
a column that stores ASCII data, so let's stop it before it
gets that far.

* Move travis CI to Python 3.7

* travis: use xenial dist

* fix newer linter warnings

Apparently bare excepts are literally Hitler, and we have some
new import sorting rules. Hooray!

* requirements: remove six

This is a dependency for sqlalchemy-utils, but we ourselves don't
depend on it directly because we've never been on Python 2 ever.

* Update requirements.txt
2019-08-10 18:39:53 -07:00

32 lines
560 B
YAML

language: python
python: "3.7"
dist: xenial
sudo: required
matrix:
fast_finish: true
cache: pip
services:
mysql
before_install:
- mysql -u root -e 'CREATE DATABASE nyaav2 DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci;'
install:
- pip install -r requirements.txt
- pip install pytest-cov
- sed "s/mysql:\/\/test:test123@/mysql:\/\/root:@/" config.example.py > config.py
- ./db_create.py
- ./db_migrate.py stamp head
script:
- ./dev.py test --cov=nyaa --cov-report=term tests
- ./dev.py lint
notifications:
email: false